Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Water leak or normal??


Wakesetter02XTi

Recommended Posts

Hey so i was out today and wanted to know is this normal?

1440b79b.jpg

Its about 2 maybe 3" of standing water. But when I pull the boat out of the water and remove the rear plug its bone dry so its like its just right there.

Thoughts?

Also, seems my auto bilge like to kick on more than normal..well maybe its normal but kind of seems off to me.

Edited by Wakesetter02XTi
Link to comment

Looks like the ballast bag connections are the issue. On mine it was the fill line where it enteres the bag was not a tight seal. I added a few O rings on the fill line and stuck it back in and the leaking stopped.

Link to comment

Yea so yesterday found out that its not the bag, its something else. I didnt fill my bags and I still get all the water. I guess next is the shaft bearings.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...