Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Alternator installation questions


Recommended Posts

Hey guys,

I just got a new alternator and I'm trying to install it. I have different colored wires from the boat when compared with the alternator. The boat has a purple, black and orange which I think is the battery?? wire. The new alternator has red, black and green (tach). I tried splicing the purple and green together, black to black and orange to alternator and it started the boat but when I turned the key off the boat kept running. So i pulled the kill switch and it kept running also. I then pulled battery cables and it still ran. So obviously something is wrong. Any help would be appreciated! I'm in a bind. Company arrives in a few hours!

Edited by aparks87
Link to comment

I didn't think you should have to, but the alternator came with 3 wires sticking out and the boat has the 3 wires coming out of it??? My new alternator only has two spots to attach wires to it where as the old one had 3. My tach wire doesn't have a home.

Link to comment

I didn't think you should have to, but the alternator came with 3 wires sticking out and the boat has the 3 wires coming out of it??? My new alternator only has two spots to attach wires to it where as the old one had 3. My tach wire doesn't have a home.

If the alt was a direct replacement the wiring should be the same so I would check to make sure the wires aren't touching each other.

The alt should have some small letters next to the terminals to let you know their function.

When I upgraded my alt the new one was "self exciting" which means it doesn't need the wire that comes from the ignition switch (12 v positive), so I put heat shrink on the loop and taped it to the harness. That could explain not being able to shut it down.

I hope this helps

Link to comment

Most alt has a switched wire and switched wire. I suspect you wired them togeather, so even with the key off the ignition is still getting power. I could guess, but really you should put a dmm on the wires to see which is which. Don't hook switched and unswitched wires togeather.

I just got a new alternator and I'm trying to install it. I have different colored wires from the boat when compared with the alternator. The boat has a purple, black and orange which I think is the battery?? wire. The new alternator has red, black and green (tach). I tried splicing the purple and green together, black to black and orange to alternator and it started the boat but when I turned the key off the boat kept running. So i pulled the kill switch and it kept running also. I then pulled battery cables and it still ran. So obviously something is wrong. Any help would be appreciated! I'm in a bind. Company arrives in a few hours!

Link to comment
  • 1 month later...

Thanks for all the input. I got it wired correctly and she's running properly.

[/quo

I know this is an old thread but I just experienced the same issue. So how did you wire it? And more importantly how did you get the engine to shut down?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...