Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

MTC screen is dead


Recommended Posts

So I was out on the water today in my 247 Wake and the MTC screen went out. I could not restart the boat. Not fuses or anything like that, the screen shows up light grey in color with a line running through it. All other Maliview and other items still work fine. Just frustrating after only 11hrs on the boat and having to still deal with overheating issues on the LSA engine still. I am starting to get a bad taste in my mouth after having owned 3 other malibus without all the fancy electronics and not having any probs. Talked to the dealer today, they are going to look at it this week. I hope this dont cut into boarding time this week and next weekend!

Saw some other topics on MTC, but is seems like those were fuse issues and other things. Any ideas out there??????????

Link to comment

So I was out on the water today in my 247 Wake and the MTC screen went out. I could not restart the boat. Not fuses or anything like that, the screen shows up light grey in color with a line running through it. All other Maliview and other items still work fine. Just frustrating after only 11hrs on the boat and having to still deal with overheating issues on the LSA engine still. I am starting to get a bad taste in my mouth after having owned 3 other malibus without all the fancy electronics and not having any probs. Talked to the dealer today, they are going to look at it this week. I hope this dont cut into boarding time this week and next weekend!

Saw some other topics on MTC, but is seems like those were fuse issues and other things. Any ideas out there??????????

Here’s one.

I cut some of the zip ties under the dash to give the wiring some slack. I had a stereo connector pull apart. We pushed it back together leaving slack for strain relief. Working fine so far...

Link to comment

So I was out on the water today in my 247 Wake and the MTC screen went out. I could not restart the boat. Not fuses or anything like that, the screen shows up light grey in color with a line running through it. All other Maliview and other items still work fine. Just frustrating after only 11hrs on the boat and having to still deal with overheating issues on the LSA engine still. I am starting to get a bad taste in my mouth after having owned 3 other malibus without all the fancy electronics and not having any probs. Talked to the dealer today, they are going to look at it this week. I hope this dont cut into boarding time this week and next weekend!

Saw some other topics on MTC, but is seems like those were fuse issues and other things. Any ideas out there??????????

you need to recheck your fuses...not that they are blown, but that they are loose in their slots not making contact, and not closing the circuit....i just wrote up a full report on this on another thread... Did you read that???ALL of my under dash fuses like 20 total, both under dash boxes...had to be tightened!!!!

me too, I tought they were firm in their slot, but only on one side of the circuit!!!! Loose Fuses!!!!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...