Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
cmb

depth finder troubles

Recommended Posts

cmb

My 03 Wakesetter 23LSV depth finder displays "BAD",,, I brought the boat to a Malibu dealer and was told that they are no longer making replacement depthfinders for 03's. Any smart guys have any ideas on how to get it fixed? I've thought about installing an aftermarket depthfinder but I don't want to mount one and make it look like a bass rig; I'd like it to work with the multifunction display.

Share this post


Link to post
Fisherlake

I am having similar issues with my 06 vlx. when I turn the ignition to the on position the gauge comes up with three functions, Depth, air temp, water temp. When the air and water temp register on the gauge the word DEPTH just disappears. What is up with that? It stays the same when underway. The owners manual leads me to believe that the depth finder is a standard feature on this boat.

Share this post


Link to post
shawndoggy

I am having similar issues with my 06 vlx. when I turn the ignition to the on position the gauge comes up with three functions, Depth, air temp, water temp. When the air and water temp register on the gauge the word DEPTH just disappears. What is up with that? It stays the same when underway. The owners manual leads me to believe that the depth finder is a standard feature on this boat.

Not standard. It's an add on. Just put one in my vride. It's about the easiest thing to do. Epoxy the sender puck in the bilge, pull puck cable up stringer under dash, mount depth module under dash, screw puck cable into depth module, plug depth module into computer (there's a plug waiting there for the depth module), and wire to ground and ignition. Cost was about $300 from Bakes.

Mine took about 45 minutes to install, 35 of which was trying to get the puck cable through the hole in the floor under the dash, because it was so full with ballast hoses and stereo wiring.

Share this post


Link to post
titanium

I am having a similar problem on my 2007 23LSV:

2 problems:

1.) Lake temp reads 150° ( I think this is part of the paddle wheel which was just replaced, possibly wrong wheel?)

2.) Depth doesn't read at all... same scenario as "Fisherlake". The boat is new to me, so where is the stock location for the depth "sender puck"? (anyone have a picture?)

Share this post


Link to post
shawndoggy

so where is the stock location for the depth "sender puck"? (anyone have a picture?)

You are looking for this:

depthglue_LG.jpg

A pic of pistol pete's here:

Share this post


Link to post
Intense

I am having a similar problem on my 2007 23LSV:

2 problems:

1.) Lake temp reads 150° ( I think this is part of the paddle wheel which was just replaced, possibly wrong wheel?)

2.) Depth doesn't read at all... same scenario as "Fisherlake". The boat is new to me, so where is the stock location for the depth "sender puck"? (anyone have a picture?)

Luckily, my depth gauge works. But my water temp gauge never leads lower that 99 degrees. For whatever reason, ever other read looks fine....depth, air temp, time, hours, etc.)

Anyone have an obvious fix?

Share this post


Link to post
Fisherlake

RE: Pistol Pete's picture. I have one of these on each side of the v-drive unit. They look similar but the one on the port side of the boat, has kind of a ring that you can unscrew. The one on the starboard side does not. They are both black and seemed to be fixed to the hull. I assumed that one was the speedo and one was the depth finder.

Edited by Fisherlake

Share this post


Link to post
titanium

From what I have found I think the lake temp reads off the paddlewheel sensor. I am witing on response from dealer.

Share this post


Link to post
Soon2BV

RE: Pistol Pete's picture. I have one of these on each side of the v-drive unit. They look similar but the one on the port side of the boat, has kind of a ring that you can unscrew. The one on the starboard side does not. They are both black and seemed to be fixed to the hull. I assumed that one was the speedo and one was the depth finder.

The one you can unscrew is the speedo paddle wheel. There are some that recommend that you remove it when pulling long distances because the air will spin the paddle, causing extra wear and tear on it. I did not remove mine when towing, but did take it out for the winter and wrapped it in a baggie to keep out bugs and webs.

My LSV came with a plug that goes in place of the paddle wheel assebmly to fill the hole. Looks the same from the top, but no wires.

Share this post


Link to post
Fisherlake

I am having similar issues with my 06 vlx. when I turn the ignition to the on position the gauge comes up with three functions, Depth, air temp, water temp. When the air and water temp register on the gauge the word DEPTH just disappears. What is up with that? It stays the same when underway. The owners manual leads me to believe that the depth finder is a standard feature on this boat.

I checked the option sheet on my VLX last night. I came with the optional depth finder. Please refer to my original question. Has anybody experienced this? Bad puck, module?

Share this post


Link to post
Wayne

I checked the option sheet on my VLX last night. I came with the optional depth finder. Please refer to my original question. Has anybody experienced this? Bad puck, module?

It's a bad depth transducer (puck) or module. Mine failed and I had the exact same behavior. Should be etiher an Airmar or Lowrance part. The Airmar interfaces directly with the instrument cluster, the Lowrance uses a sending/receiving module in combination with the puck. Figure out which one you have and you can get the part numbers off of them to find a replacement part if it's not still under warenty. The Lowarnce module is usually under the dash with the puck some where on the hull. My '09 Response had an Airmar transducer and the wire had a tag on it near the plug under the dash.

Usually if the transducer is bad, you don't hear an audible "clicking" sound when it is powered up.

Share this post


Link to post
Hardy

My 2004 23 LSV started showing BAD on the depth guage continuously. Decided to buy the Hummingbird and mount where the old Sony Control was just over the right knee on dash. Anyway, in process of installing, found that a black wire had disconnected from the ground block (broke just after the crimp). Voila, connected the ground, and it started working again!

Doubt I can return the Hummingbird, but if this post saves someone else 110$, I'll be happy.

Share this post


Link to post
RosscoB

I think I'm having the same problem on my 05 I just purchased, but I'm not sure.

The depth finder works about 50% of the time. When it is not working, I can't select it from the menu. However, when it starts off working it switches between the depth and a reading of NRES. Is there any clear cut way to determine if it's the sender or the module between the sender and the gauge before I start replacing pieces?

Share this post


Link to post
Dale974

I realize this is an old thread, but i just picked up a 06 VLX and would like to have the depth finder in the dash.  Seems as though i can get a module thru bakes for it, but they're telling me i can no longer get the transducer which has been discontinued.  Has anyone else run into this and is there another compatible one, or am i going to be stuck with having to mount an extra gauge and stand alone depth finder system in the boat?  Any advice would be great.  thanks

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...