Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Wake N Bake

BALLAST SCREEN ON 07 V-RIDE

Recommended Posts

Wake N Bake

Hi, i am all over this fourm getin my boat in check, when i go to hit the ballast button on the screen it doesnt do anything am I missing something or is my screen broken?? :unsure: is there a way to fix this without buying a new one?? evryother button seems to work..

Share this post


Link to post
shawndoggy

Hi, i am all over this fourm getin my boat in check, when i go to hit the ballast button on the screen it doesnt do anything am I missing something or is my screen broken?? :unsure: is there a way to fix this without buying a new one?? evryother button seems to work..

that same screen was used on other wakesetter models of the same vintage. I'm 99.9% certain that ballast monitoring was not an option that was offered on the vrides, but that the reason it's there on your screen is that it was an option on the higher end boats. Does your depth gauge work? My boat didn't come with the module for that either, even though I've got a screen for it.

Share this post


Link to post
jtvride

that same screen was used on other wakesetter models of the same vintage. I'm 99.9% certain that ballast monitoring was not an option that was offered on the vrides, but that the reason it's there on your screen is that it was an option on the higher end boats. Does your depth gauge work? My boat didn't come with the module for that either, even though I've got a screen for it.

:plus1:

Share this post


Link to post
Ndawg12

:plus1:

:plus1: :plus1: Mine does have a depth gauge but I have to subtract 2' from what ever it says :Doh:

Share this post


Link to post
board brained

Hi, i am all over this fourm getin my boat in check, when i go to hit the ballast button on the screen it doesnt do anything am I missing something or is my screen broken?? :unsure: is there a way to fix this without buying a new one?? evryother button seems to work..

what button are you pushing? I have an 07 vride and mine says N/A on the screen (you have to have a fancy boat to get those options :biggrin: )......however my depth guage works and is accurate....I think

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...