Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
ecj

Suspected air in fuel system

Recommended Posts

ecj

Please help, I am going crazy trying to figure out this problem...I apologize for the length of this post.

Cannot hold 3000 rpm. When increasing rpm and nearing 2900 rpm and trying to increase power, will jump to over 3100 rpm. Same thing happens on way down, nearing 3100 rpm, a slow decrease in power and it jumps back to less than 2900 rpm.

The following has been replaced: fuel pick-up, fuel shut-off valve at tank eliminated, fuel lines to the fuel pump, both fuel filters, (low pressure before pump, hi-press after pump), fuel pump, fuel pressure regulator, ECM, plugs, cap, rotor, wires, injectors cleaned.

Tried elimating the hi-press fuel filter by using fuel line from pump to fuel block. Anytime you "open" fuel system to replace a component, it runs fine for 5-10 minutes. Then the problem described above returns. So you say, "put a fuel pressure guage on to see what's happening when it starts acting up". Here's the strange thing, putting a gauge on the schreader valve on the fuel rail elliminates the problem, pressure is good and steady, and it will not act up. In fact putting the coupling for the pressure gauge, which includes approx 6" of hose elliminates the problem. This makes me believe a small ammount of air is present which becomes a problem at that fuel flow rate demanded by that RPM range, and by putting the guage hardware on it allows the air to escape before getting through the rest of the fuel rail,(acting like an air accumulator). I'm running out of ideas. I'm thinking a fuel pressure gauge hooked up may be a permenant fixture to my fuel system. Is the enemy of good enough perfection here? If you made it this far, thank you for even reading this!

Boat: 1999 Sunsetter VLX, Monsoon 2, MEFI-1

Share this post


Link to post
Sixball

Replace the schreader valve. Throttle position sensor. Dontknow.gif

Share this post


Link to post
ecj

Many thanks for the reply.

I neglected to add that in the original post, I replaced both, (TPS and schreader valve). The other sensors have been tested recently and a buddy has the same year sunsetter (but a DD), earlier I swapped the other sensors one by one with his, i.e. MAP, coolant temp, are there others, I'm pulling a blank.

Thanks again.

Share this post


Link to post
tvano

probably not the culprit but it's free and easy to inspect the screen at the fuel pump intake.

i can't imagine the circumstance where is would impact fuel delivery ONLY at the 3k rpm mark but, again, it's free n easy to cross it off the list of potential problems.

almost sounds like a control problem; like the fuel / air ratio mapping is sick. wrong calibration? wrong chip?

you the original owner? ecm been replaced because of a prior problem?

it may be worth checking w dealer for new calibrations.

this rig has run great before?

Share this post


Link to post
ecj

Thanks for your input guys, I appreciate the brainstorming. I did check the screen before the fuel pump, wish it was that.

A little more info, I am the second owner, I've had it 1 1/2 years. It did run well at one point but developed a surging problem between 1800-2200 rpm, (more than what it has now between 2900-3100). After I replaced much of the components described above a mechanic diagnosed as the ECM. He replaced the ECM, (new ac delco unit but with a mercruiser program), it ran perfectly well except it would RPM limit at 4600 RPM. I had to run it for a month with this ECM, I used it nearly everyday, (last summer), like I said ran great other than the RPM limiter. I discussed problem with mech and he agreed we could flash with the Indmar program. He sent to Indmar and they flashed with thier numbers. Now it ran like total crap, surging at several RPM bands. Tried another re-flash, same results. Indmar was now curious, they wanted to see what was wrong with these ECM's. We sent the original ECM and the re-flashed new ECM, they couldn't find any problems with them but sent us a new Indmar ECM, (many thanks to Indmar). With this ECM and a really good cleaning of the injectors, (both on rail cleaning and taking them off the rail), we are left with this annoying RPM band where it will not hold 3000, (can get 2900, can get 3100). It runs great in all the other bands. (BTW The mech has a 2000 sunsetteer VLX, to rule out injectors, we swapped his for mine, same problem.)

Now if you put a fuel pressure gauge on the rail, problem goes away, makes me think air in the system. I originally started asking about this problem with a post about the schreader valve on the fuel rail, many thanks to all responding to that one, including Bake's marine. I feel TV's Dr House, except I'm not as cranky and don't walk with a cane. Please help, all input welcome.

Share this post


Link to post
footnlongline

Thanks for your input guys, I appreciate the brainstorming. I did check the screen before the fuel pump, wish it was that.

A little more info, I am the second owner, I've had it 1 1/2 years. It did run well at one point but developed a surging problem between 1800-2200 rpm, (more than what it has now between 2900-3100). After I replaced much of the components described above a mechanic diagnosed as the ECM. He replaced the ECM, (new ac delco unit but with a mercruiser program), it ran perfectly well except it would RPM limit at 4600 RPM. I had to run it for a month with this ECM, I used it nearly everyday, (last summer), like I said ran great other than the RPM limiter. I discussed problem with mech and he agreed we could flash with the Indmar program. He sent to Indmar and they flashed with thier numbers. Now it ran like total crap, surging at several RPM bands. Tried another re-flash, same results. Indmar was now curious, they wanted to see what was wrong with these ECM's. We sent the original ECM and the re-flashed new ECM, they couldn't find any problems with them but sent us a new Indmar ECM, (many thanks to Indmar). With this ECM and a really good cleaning of the injectors, (both on rail cleaning and taking them off the rail), we are left with this annoying RPM band where it will not hold 3000, (can get 2900, can get 3100). It runs great in all the other bands. (BTW The mech has a 2000 sunsetteer VLX, to rule out injectors, we swapped his for mine, same problem.)

Now if you put a fuel pressure gauge on the rail, problem goes away, makes me think air in the system. I originally started asking about this problem with a post about the schreader valve on the fuel rail, many thanks to all responding to that one, including Bake's marine. I feel TV's Dr House, except I'm not as cranky and don't walk with a cane. Please help, all input welcome.

Is this doing this under load? The fact that it goes away with the pressure gauge attached kinda narrows it down for you, is this consistant?.

Share this post


Link to post
ecj

This is under load, i.e. on the water underway, I dont have to be towing for the problem to occur. It is consistent in that pressure gauge attachment on fuel rail = runs great, off = RPM "catch". Also if you open fuel system to say replace filter, pump, line etc..after of course priming system, runs great for 5 - 10 minutes, (without press guage on), then re-occurs.

Share this post


Link to post
footnlongline

This is under load, i.e. on the water underway, I dont have to be towing for the problem to occur. It is consistent in that pressure gauge attachment on fuel rail = runs great, off = RPM "catch". Also if you open fuel system to say replace filter, pump, line etc..after of course priming system, runs great for 5 - 10 minutes, (without press guage on), then re-occurs.

Wow, that is baffeling. Do you have a inline filter on your motor? or a water seperating filter?. Maybe a vacuum leak, that is weird!

Share this post


Link to post
ecj

Wow, that is baffeling. Do you have a inline filter on your motor? or a water seperating filter?. Maybe a vacuum leak, that is weird!

2 filters, inline low pressure, after the pump hi-press, both replaced. Even tried by-passing high-press filter. No water/fuel separator, I hear Indmar discourages them.

Share this post


Link to post
medicdiver

Fuel Pressure Regulator? Which motor do you have?? try hooking up a vacumn guage to the engine as wel and see if there is a drop in vacumn at the specified RPM range.

Share this post


Link to post
ecj

Fuel Pressure Regulator? Which motor do you have?? try hooking up a vacumn guage to the engine as wel and see if there is a drop in vacumn at the specified RPM range.

replaced the fuel press regulator, monsoon II, the vacuum gauge is a good idea, we'll give that a try.

Again, thanks for the input.

Share this post


Link to post
Engine Nut

replaced the fuel press regulator, monsoon II, the vacuum gauge is a good idea, we'll give that a try.

Again, thanks for the input.

Take a look at the fuel lines that connect the fuel rails together in the front and back of the fuel rails. Are the crossover lines solid metal lines or do they have metal ends and a short piece flexible rubber line in the middle. If they are solid,you might be experiencing a condition called fuel hammer. That engine has batch fire fuel injectors ... when one injector fires 4 injectors fire. Under certain conditions, when all the injectors close at the same time it creates a shock wave in the fuel system which can have a disruptive effect on the fuel flow. The crossover lines with the rubber center act as a dampner to help absorb the shock wave ... like an accumulator in a hydraulic system. If you have the solid lines, they can be replaced with the newer lines with the rubber section.

Larry Engelbert

Indmar Customer Service

Share this post


Link to post
ecj

Take a look at the fuel lines that connect the fuel rails together in the front and back of the fuel rails. Are the crossover lines solid metal lines or do they have metal ends and a short piece flexible rubber line in the middle. If they are solid,you might be experiencing a condition called fuel hammer. That engine has batch fire fuel injectors ... when one injector fires 4 injectors fire. Under certain conditions, when all the injectors close at the same time it creates a shock wave in the fuel system which can have a disruptive effect on the fuel flow. The crossover lines with the rubber center act as a dampner to help absorb the shock wave ... like an accumulator in a hydraulic system. If you have the solid lines, they can be replaced with the newer lines with the rubber section.

Larry Engelbert

Indmar Customer Service

That could be a possibility. The boat is in the shop, but I can check tomorrow. I want to say the cross over rail is solid fuel line. It's ironic you bring this up because I looked at my buddy's 99 sunsetter LXi today to see if his fuel system was the same, i.e. the fuel distribution block and general layout. (His of course runs perfectly!). His layout was the same BUT I noticed that his crossover line was rubber, didn't think much of it at the time.

If this is it is it part I can get from indmar, a malibu dealer?...thanks for the looking at my dilema

Share this post


Link to post
ecj

That could be a possibility. The boat is in the shop, but I can check tomorrow. I want to say the cross over rail is solid fuel line. It's ironic you bring this up because I looked at my buddy's 99 sunsetter LXi today to see if his fuel system was the same, i.e. the fuel distribution block and general layout. (His of course runs perfectly!). His layout was the same BUT I noticed that his crossover line was rubber, didn't think much of it at the time.

If this is it is it part I can get from indmar, a malibu dealer?...thanks for the looking at my dilema

I was so excited you might have the answer my grammar got away from me...is it A part I can get from Indmar...thanks for looking at my dilemma

Share this post


Link to post
Sixball

Very good call Larry. It will be interesting to get an answer if it checks out. You will let us know ecj!!!!!

Very frustrating for the owner but always good to know what the final fix is.

Share this post


Link to post
electricjohn

Take a look at the fuel lines that connect the fuel rails together in the front and back of the fuel rails. Are the crossover lines solid metal lines or do they have metal ends and a short piece flexible rubber line in the middle. If they are solid,you might be experiencing a condition called fuel hammer. That engine has batch fire fuel injectors ... when one injector fires 4 injectors fire. Under certain conditions, when all the injectors close at the same time it creates a shock wave in the fuel system which can have a disruptive effect on the fuel flow. The crossover lines with the rubber center act as a dampner to help absorb the shock wave ... like an accumulator in a hydraulic system. If you have the solid lines, they can be replaced with the newer lines with the rubber section.

Larry Engelbert

Indmar Customer Service

So his pressure gauge is acting as a shock(wave) absorber. WOW It's amazing what fluid dynamics can do to you at times. I've heard of steam hammer, but never fuel line hammer. Good luck ecj. I think Larry nailed it for you. I have been watching this thread with interest.

Edited by electricjohn

Share this post


Link to post
ecj

So his pressure gauge is acting as a shock(wave) absorber. WOW It's amazing what fluid dynamics can do to you at times. I've heard of steam hammer, but never fuel line hammer. Good luck ecj. I think Larry nailed it for you. I have been watching this thread with interest.

I will definitely let you guys know!!! I hope I can try out Monday, (it's raining thru the weekend, at least there's not ice on the lake, like for you Northern clime folks).

Share this post


Link to post
SmoothWaterMan

Yes, you can order the parts from any Malibu/Indmar dealer.

Peter :)

Share this post


Link to post
tvano

So his pressure gauge is acting as a shock(wave) absorber. WOW It's amazing what fluid dynamics can do to you at times. I've heard of steam hammer, but never fuel line hammer. Good luck ecj. I think Larry nailed it for you. I have been watching this thread with interest.

are steam and fuel line related to mc?Whistling.gif

Share this post


Link to post
Engine Nut

I was so excited you might have the answer my grammar got away from me...is it A part I can get from Indmar...thanks for looking at my dilemma

The Indmar part number for the crossover line is S786129.

Share this post


Link to post
ecj

The Indmar part number for the crossover line is S786129.

So the rain stopped Sat, superbowl Sun passed yesterday and I was able to get to the lake today, (Mon). I DID have solid crossover lines and my buddy's 99 HAD the rubber lines and put his in and....drumroll....worked perfectly, 4.0 in all ranges!!! Very, very happy. On a sidenote if my buddy even falls skiing in the next 8 years behind his boat, he will blame it on me for cracking open his fuel system, say it must have hiccuped. (His is the boat that I swapped all the sensors with one by one, so I was getting blamed anyway.) As TVANO said, the pressure gauge hose was acting like an accumulator, I thought it was accumulating air, not dampning a fluid shock.

Kudos to Larry, thank you very much!! What's your favorite poison? I'm sure a bottle can find it's way to TN!

Share this post


Link to post
Engine Nut

So the rain stopped Sat, superbowl Sun passed yesterday and I was able to get to the lake today, (Mon). I DID have solid crossover lines and my buddy's 99 HAD the rubber lines and put his in and....drumroll....worked perfectly, 4.0 in all ranges!!! Very, very happy. On a sidenote if my buddy even falls skiing in the next 8 years behind his boat, he will blame it on me for cracking open his fuel system, say it must have hiccuped. (His is the boat that I swapped all the sensors with one by one, so I was getting blamed anyway.) As TVANO said, the pressure gauge hose was acting like an accumulator, I thought it was accumulating air, not dampning a fluid shock.

Kudos to Larry, thank you very much!! What's your favorite poison? I'm sure a bottle can find it's way to TN!

I am very happy your problem was resolved. The fact that the problem went away when using the fuel pressure tester was the tip-off for me. Your satisfaction is all the reward I need. I love solving problems and keeping customers happy. Just do me a favor and make sure the next boat you buy has an Indmar engine.

Share this post


Link to post
Lance B. Johnson

So his pressure gauge is acting as a shock(wave) absorber. WOW It's amazing what fluid dynamics can do to you at times. I've heard of steam hammer, but never fuel line hammer. Good luck ecj. I think Larry nailed it for you. I have been watching this thread with interest.

I learned something today too, never heard of fuel hammer. I suppose the gauge is the clue like you said, works like a dampener. Pretty cool.

Share this post


Link to post
Sixball

Larry Engelbert gets a big + Rockon.gifNotworthy.gifClap.gifThumbup.gifCheers.gif:salute:

Share this post


Link to post
nbeihl

I chased a problem for a year and no one could figure it out. I called Skidim.com and they were able to help me over the phone in 2 seconds. They are quite knowledgeable and will ship you the parts you need in no time. Highly recommended.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...