Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
abruno

'03 Wakesetter VLX Ballast Issue

Recommended Posts

abruno

I own a 2003 Wakesetter VLX and recently the drain bilge on the center ballast stopped working. It has always operated slower than the the other drains, so I think there has always been a slight problem. I checked the fuses, all are fine. I am looking to replace the bilge, this site: http://www.bakesonline.com/detail.aspx?ID=993 claims it is Malibu OEM but I know my boat uses Rule pumps for the ballast.

Has anyone replaced a pump before/can recommend one to buy?

Share this post


Link to post
Sippi

I don't know about the fitting sizes on yours, but I love the performance out of my tsunami 1200 gph pumps. You don't have to get the exact one that's currently in your boat, just make sure it has the same inlet/outlet size so you can directly replace them.

Share this post


Link to post
REW
I don't know about the fitting sizes on yours, but I love the performance out of my tsunami 1200 gph pumps. You don't have to get the exact one that's currently in your boat, just make sure it has the same inlet/outlet size so you can directly replace them.

Have you installed one through the hull yourself? do the pumps come with all that will be needed or will I need a fitting?

Share this post


Link to post
Sippi

Are you talking about the pump that drains your center ballast tank or the actual bilge pump that sits pretty much on the bottom of your bilge area?

Share this post


Link to post
abruno
Are you talking about the pump that drains your center ballast tank or the actual bilge pump that sits pretty much on the bottom of your bilge area?

This is definitely the drain pump, I know because I can see the tubing that connects it to the center ballast sack.

Share this post


Link to post
abruno
I don't know about the fitting sizes on yours, but I love the performance out of my tsunami 1200 gph pumps. You don't have to get the exact one that's currently in your boat, just make sure it has the same inlet/outlet size so you can directly replace them.

Yeah, I'll make a point to measure the tubes next chance I get. Are the inlet/outlet sizes generally listed when you purchase a bilge?

Share this post


Link to post
Sippi

Yeah, do you know how many GPH your current pump is? Most of them have the same inlet/outlet for the same GPH. I think te 500 and 800 tsunamis are both the same then it gets bigger with the 1200.

Share this post


Link to post
abruno
Yeah, do you know how many GPH your current pump is? Most of them have the same inlet/outlet for the same GPH. I think te 500 and 800 tsunamis are both the same then it gets bigger with the 1200.

Yeah, it says 700gph on the top of the pump, where it's a different manufacturer I was wondering if there was some standard across the industry.

Share this post


Link to post
Sippi

Ok, did a little research for you. The rule pumps that are 500-800 gph are 3/4" inlet/outlet. Which means you can direct replace them with tsunamis 800 if you wanted, or just get another rule. Rule's 800 gph is the same if you wanted to go that route. I know you can get the rule pumps at basspro, but you can pick up a tsunami 800 gph pump at walmart for convenience.

Share this post


Link to post
abruno
Ok, did a little research for you. The rule pumps that are 500-800 gph are 3/4" inlet/outlet. Which means you can direct replace them with tsunamis 800 if you wanted, or just get another rule. Rule's 800 gph is the same if you wanted to go that route. I know you can get the rule pumps at basspro, but you can pick up a tsunami 800 gph pump at walmart for convenience.

Wow thanks for doing that!! Hope it didn't put you out too much. I'm fine swapping brands so long as the pump has the same electrical specs as the Rule(can't see why it wouldn't), so once I check that out I'll make a purchase. Thanks again.

Share this post


Link to post
abruno

Just wanted to say 'thanks' to everyone who helped out, as a followup I swapped in a new 800gph tsunami this weekend and it runs great, I still have to water test it but the motor runs fine and I have great expectations for it.

Thanks again.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...