Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Manitou

Bilge Pump Help

Recommended Posts

Manitou

Need some help with my bilge pump. I searched all over but couldn't seem to find anything.

I have a '97 Echelon LX. It runs super well. I've never had a problem with the bilge pump before but the battery was dead yesterday and in looking for the cause I found the bilge wasn't draining but I heard the motor running. The float switch was obviously activated. It could have been running for 24-36 hours or so without emptying. I disconnected the battery and heard the motor stop.

1. How do I find/access the bilge pump on this boat?

2. Could it be some debris issue or impellor trouble or does this sound like a new pump is required?

Thanks for any help!

Share this post


Link to post
luvtheBU

I have a 94 Echelon and my bilge pump is right in front of the engine on the floor near the bilge drain.

Share this post


Link to post
JasonK

Same thing happened to me last week. Tried everything to get it to work right, but after draining the battery twice I got a new one.

Share this post


Link to post
Manitou
I have a 94 Echelon and my bilge pump is right in front of the engine on the floor near the bilge drain.

Sweet! Thanks. I removed the plastic cover in front of the engine in the bilge and found the pump. The motor/cover/float switch had popped of its base. I snapped it back on and balance has been restored to my universe!! Thanks for your help.

Share this post


Link to post
Baddog

Darned easy things to work on. For the first time ever, this spring mine wouldn't work at all. Pulled it out, poped it open, clean some crud off the shaft by the impellor and now it is perfect.

Share this post


Link to post
srock

I took the cover off and discarded it after not being able to access the pump on the water quickly. Poor design in my opinion. I bunch of debris and a load of water over the bow will prove my point.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...