Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
bpalmer115

Overheating problems. Help please

Recommended Posts

bpalmer115

I tried to take the boat out today with some family, but there was a weird smell coming from the boat. There was smoke coming out of the back of the boat but none in the engine compartment. The oil pressure, and the engine temp. appear to be fine. The gauge is reading the air temp and depth and everything else fine, but it is saying the water temp is at 112 degrees even though it's only in the 70's. When I try to reverse or go faster the water temp rises until the boat starts beeping and displays TEMP on the gauge. I don't know if there is something wrong with the coolant or the gauge or oil or what? Please help me.

Share this post


Link to post
68Slalom

I would have the impeller checked Thumbup.gif you should be good to go

Share this post


Link to post
mlange

Check the impeller as well as clean out any weeds or other crap at the filter on the inlet side of the trans cooler.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...