Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Jim

Engine running rough...

Recommended Posts

Jim

...at idle speed.

My 00' Sunsetter with 310 vortec is running very rough at idle speed. I have changed the cap and rotor,plugs,oil filter,fuel filter(spin-on) along with other regular maintainance items. I haven't completely ruled out moisture but that doesn't appear to be the issue. I'm starting to wonder if I might need to rebuild the carb(417 hrs).

Any thoughts?

Share this post


Link to post
jgouveia3
...at idle speed.

My 00' Sunsetter with 310 vortec is running very rough at idle speed. I have changed the cap and rotor,plugs,oil filter,fuel filter(spin-on) along with other regular maintainance items. I haven't completely ruled out moisture but that doesn't appear to be the issue. I'm starting to wonder if I might need to rebuild the carb(417 hrs).

Any thoughts?

if its never been rebuilt and high humidity NE weather, that would be my guess. I used to do my MC carb almost every season here.

Share this post


Link to post
wake309

i just did mine on my 02 wakesetter

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...