Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
wsdud

engine overheating

Recommended Posts

wsdud

I changed the impeller but still over heating.

Share this post


Link to post
Bobby Light
I changed the impeller but still over heating.

Take the hose off and check for blockage, and in the screen.

Share this post


Link to post
apwrx

I second checking the screen.I had my hose blow off and the screen was clogged with old impeller,existing one was fine it must of been from the one before,anyhow it runs cooler now.

Share this post


Link to post
SFD
I second checking the screen.I had my hose blow off and the screen was clogged with old impeller,existing one was fine it must of been from the one before,anyhow it runs cooler now.

Does he know where the screen is located ?

Share this post


Link to post
apwrx
I second checking the screen.I had my hose blow off and the screen was clogged with old impeller,existing one was fine it must of been from the one before,anyhow it runs cooler now.

Does he know where the screen is located ?

Well he does now,Another thought is bad thermostat.

cooling.jpg

Edited by apwrx

Share this post


Link to post
wsdud
I second checking the screen.I had my hose blow off and the screen was clogged with old impeller,existing one was fine it must of been from the one before,anyhow it runs cooler now.

Does he know where the screen is located ?

Well he does now,Another thought is bad thermostat.

cooling.jpg

Share this post


Link to post
wsdud
I second checking the screen.I had my hose blow off and the screen was clogged with old impeller,existing one was fine it must of been from the one before,anyhow it runs cooler now.

Does he know where the screen is located ?

Well he does now,Another thought is bad thermostat.

cooling.jpg

Thanks for the info. I checked the screen and it was clear. How can I check the thermostat? Is there another water pump in the engine?

Share this post


Link to post
WaveMake'nLSV

I bet your T-stat is frozen shut.

Thanks for the info. I checked the screen and it was clear. How can I check the thermostat? Is there another water pump in the engine?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...