Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
phall925

Indmar CAT Rant - Warning upset customer

Recommended Posts

phall925

Ok So I bought an 08 VLX took delivery in March. We have put 50 hours on her so far and this boat is great.........well everything excet the idiots at Indmar and their horrible Cat_A Temp sensors. A little back story here about a month or so ago I got a Service Required just after I got the boat back from its 20 hour service check. I looked through the fault codes and it said both CAT_A and CAT_B temp sensor overheat or low voltage. Called the mechanic he came out checked the boat cleared the codes ran the boat with his cpu attached said that the sensors could have gone bad but that there is no problem with the motor and he would get new sensors from Indmar. He finally got them a few weeks ago and installed them everything was fine. This past weekend I was enjoying the first official weekend of summer and guess what?....yeah Service Required checke the fault codes and Cat_a Temp Sensor problem again. I have called the mechanic and he is going to go and change the sensors again.

Now if anyone from Indmar or Malibu is reading this. WTF IS GOING ON?

Are you guys planning on addressing this issue or what? I mean if you are going to ask us to pay 65K and up for a boat I expect on that is not always under the wrench. If I wanted a piece o $h!T I would have bought a Moomba and saved some coin. I bought a quality boat and that is what I want. If this is sign of things to come I will be very upset.

End Rant

Preston

Share this post


Link to post
VinRLX

You may have one of the motors with restricted water flow around the CATS. Ask your dealer to look into it.

Share this post


Link to post
99response

Yeah your isolated case of two fault codes must indicate a wide spread CAT issue....you should definitly start flamming Malibu and Indmar all over the internet and see how anxious they are to go the extra mile to help you out.

Share this post


Link to post
Black&Blue'Bu

Yeah same thing on my 08 VTX but it was a disconnected wire at the sensor. Reconnected the wire but dealers computer was broken and could not get the code to go away. I have to hit "e" button to make fault code go away for a while but the manaual also says that after 3 full temp cycles on the engine if the fault is fixed it should wipe the fault out. Not a real big deal for me now but we will see if it continues or goes away on my next temp cycle.

Not to hijack the post but I am also not real happy with windshield quality and the swim platform was screwed to the supports with screws that are on an angle, or are not screwed in all the way or have a head broken and screw shank still in. Again somewhat minor overall but I agree for $65 K + you don't really want to see these types of quality issues.

After having said this I really do love this boat and how it performs.

Edited by wipeoutwally

Share this post


Link to post
phall925

99response,

I am detecting levels of sarcasim.....anyway I feel a flame is necessary do to the fact that it is becomming more of a widesread issue just call your local Malibu servie advisor and ask them. My only point was WTF is going on with these motors and for what we pay we should not be guinie pigs they should have all the kinks worked out for the amount of money that seem to have no problem taking off our hands. I understand that there are normal amounts of glitches every now and then with anything, but some customer service would be nice every now and then.

Share this post


Link to post
99response

Customer service? Sounds like your dealer is/will take care of it so what's the issue. FWIW the CAT's had virtually no problems last year in the first year of production on a totally new design. There are going to be problems with these new systems, period. But they are required in CA now. If you didn't want the CAT's or the potential headaches you should have ordered the LCR.

Share this post


Link to post
Hman442

I have two friends with Moomba '23's. They actually are really nice boats - esp for the money.

Share this post


Link to post
pennery
Ok So I bought an 08 VLX took delivery in March. We have put 50 hours on her so far and this boat is great.........well everything excet the idiots at Indmar and their horrible Cat_A Temp sensors. A little back story here about a month or so ago I got a Service Required just after I got the boat back from its 20 hour service check. I looked through the fault codes and it said both CAT_A and CAT_B temp sensor overheat or low voltage. Called the mechanic he came out checked the boat cleared the codes ran the boat with his cpu attached said that the sensors could have gone bad but that there is no problem with the motor and he would get new sensors from Indmar. He finally got them a few weeks ago and installed them everything was fine. This past weekend I was enjoying the first official weekend of summer and guess what?....yeah Service Required checke the fault codes and Cat_a Temp Sensor problem again. I have called the mechanic and he is going to go and change the sensors again.

Now if anyone from Indmar or Malibu is reading this. WTF IS GOING ON?

Are you guys planning on addressing this issue or what? I mean if you are going to ask us to pay 65K and up for a boat I expect on that is not always under the wrench. If I wanted a piece o $h!T I would have bought a Moomba and saved some coin. I bought a quality boat and that is what I want. If this is sign of things to come I will be very upset.

End Rant

Preston

Doesn't Moomba use the Same Engines?

Share this post


Link to post
Malibuzer

Yes they do. So does Supra, and Mastercraft since 2007.

Share this post


Link to post
DIE2SURF
99response,

I am detecting levels of sarcasim.....anyway I feel a flame is necessary do to the fact that it is becomming more of a widesread issue just call your local Malibu servie advisor and ask them. My only point was WTF is going on with these motors and for what we pay we should not be guinie pigs they should have all the kinks worked out for the amount of money that seem to have no problem taking off our hands. I understand that there are normal amounts of glitches every now and then with anything, but some customer service would be nice every now and then.

I can understand your being very upset. But don't forget the old adage: "You can catch a lot more flies with honey that you can with vinegar". Perhaps be polite but persistent with the dealer/Indmar/Malibu. Then, for your trouble, maybe think of something that you were planning on buying and ask for a big discount (or even free) for your repeated troubles. I'm not judging; just trying to help you find a way to make the sting a little less painful. Good luck with your boat.

Share this post


Link to post
bb01760
Ok So I bought an 08 VLX took delivery in March. We have put 50 hours on her so far and this boat is great.........well everything excet the idiots at Indmar and their horrible Cat_A Temp sensors. A little back story here about a month or so ago I got a Service Required just after I got the boat back from its 20 hour service check. I looked through the fault codes and it said both CAT_A and CAT_B temp sensor overheat or low voltage. Called the mechanic he came out checked the boat cleared the codes ran the boat with his cpu attached said that the sensors could have gone bad but that there is no problem with the motor and he would get new sensors from Indmar. He finally got them a few weeks ago and installed them everything was fine. This past weekend I was enjoying the first official weekend of summer and guess what?....yeah Service Required checke the fault codes and Cat_a Temp Sensor problem again. I have called the mechanic and he is going to go and change the sensors again.

Now if anyone from Indmar or Malibu is reading this. WTF IS GOING ON?

Are you guys planning on addressing this issue or what? I mean if you are going to ask us to pay 65K and up for a boat I expect on that is not always under the wrench. If I wanted a piece o $h!T I would have bought a Moomba and saved some coin. I bought a quality boat and that is what I want. If this is sign of things to come I will be very upset.

End Rant

Preston

Not wanting to hijack, but having my circulating hose blow up after 4 hours on my new 2007 RLXI and fill the boat with water does not up my belief in Indmar's quality. My first weekend of the summer was also ruined, my dealer stepped in and overnighted the part, but the weekend was a goner.

BB

Share this post


Link to post
Malibuzer

I guess the question would have to be, Did Inmar make that hose or another company. Not trying to ruffle feathers, just wanting a clarification. BTW I would be pissed if I couldn't use my boat on the first weekend either.

Share this post


Link to post
99response
I guess the question would have to be, Did Inmar make that hose or another company. Not trying to ruffle feathers, just wanting a clarification. BTW I would be pissed if I couldn't use my boat on the first weekend either.

I was going to say that but I guess it does not matter. Indmar's name is on the final product.

I doubt Indmar makes the temp senors for the CAT's either.

-Chris

Share this post


Link to post
pennery
Ok So I bought an 08 VLX took delivery in March. We have put 50 hours on her so far and this boat is great.........well everything excet the idiots at Indmar and their horrible Cat_A Temp sensors. A little back story here about a month or so ago I got a Service Required just after I got the boat back from its 20 hour service check. I looked through the fault codes and it said both CAT_A and CAT_B temp sensor overheat or low voltage. Called the mechanic he came out checked the boat cleared the codes ran the boat with his cpu attached said that the sensors could have gone bad but that there is no problem with the motor and he would get new sensors from Indmar. He finally got them a few weeks ago and installed them everything was fine. This past weekend I was enjoying the first official weekend of summer and guess what?....yeah Service Required checke the fault codes and Cat_a Temp Sensor problem again. I have called the mechanic and he is going to go and change the sensors again.

Now if anyone from Indmar or Malibu is reading this. WTF IS GOING ON?

Are you guys planning on addressing this issue or what? I mean if you are going to ask us to pay 65K and up for a boat I expect on that is not always under the wrench. If I wanted a piece o $h!T I would have bought a Moomba and saved some coin. I bought a quality boat and that is what I want. If this is sign of things to come I will be very upset.

End Rant

Preston

Not wanting to hijack, but having my circulating hose blow up after 4 hours on my new 2007 RLXI and fill the boat with water does not up my belief in Indmar's quality. My first weekend of the summer was also ruined, my dealer stepped in and overnighted the part, but the weekend was a goner.

BB

Are we talking the hose that goes from the raw water intake to the impeller? There is probably an easier place to get one of those than the dealer.. What could that Hose possibly be worth?.. I think it would have been more trouble getting the dealer involved than the $20 that it costs to go get another one somewhere else and you could have enjoyed your weekend on the water... No one builds a perfect boat and they never will.. What makes a good boat manufacturer is how they fix their screw ups.. If you are looking for a boat that is maintenence and trouble free let me know when you find it.. I think that blaming Indmar for a hose that blew up is not only petty but a little rediculous.. Just my opinion of course.

Share this post


Link to post
bb01760

If it was that simple I would have done so.

It is the hose from the Thermostat to the circulating pump that has a very unique shape. I know from searching this forum that I m not the only person with a split hose.

After paying a big chunk of $$$ I do expect everything to be PERFECT. If I buy cheap I have low expectations, when I pay big cash there is usually a good reason for it. In this case just like the original poster I do expect top quality.

Share this post


Link to post
MalibuTime
Yeah your isolated case of two fault codes must indicate a wide spread CAT issue....you should definitly start flamming Malibu and Indmar all over the internet and see how anxious they are to go the extra mile to help you out.

I though maybe a little short tempered too. So far, the dealer and Indmar has stepped up to service the problem both times, even coming out to your location, and you are calling them idiots? Man, what do you do when you get crappy service? Guns.gif You should always walk away and come back a few minutes later and reread a rant like that before you post it.

Edited by TheBlackPearl

Share this post


Link to post
Hydrofoiljunky

Huh? That's weird, my new piece of Shiet Moomba has about 75 hrs on it now, also taken over in March, but I havn't seemed to have any problems. Strange........... End Sarcasm. Sorry I feel better now.

Share this post


Link to post
footnlongline

This thread is" flippin sweet" Clap.gif

Share this post


Link to post
pennery
If it was that simple I would have done so.

It is the hose from the Thermostat to the circulating pump that has a very unique shape. I know from searching this forum that I m not the only person with a split hose.

After paying a big chunk of $$$ I do expect everything to be PERFECT. If I buy cheap I have low expectations, when I pay big cash there is usually a good reason for it. In this case just like the original poster I do expect top quality.

I can see that hose being more difficult for sure..

What happens when a tire blows out on your new trailer do you blame Malibu? I think the hose is a bit unexpected and the dealer you got the hose from seemed like he did the right thing by sending you a new one overnight.. I would think service like that should be commended and appreciated...

Share this post


Link to post
bb01760
If it was that simple I would have done so.

It is the hose from the Thermostat to the circulating pump that has a very unique shape. I know from searching this forum that I m not the only person with a split hose.

After paying a big chunk of $$$ I do expect everything to be PERFECT. If I buy cheap I have low expectations, when I pay big cash there is usually a good reason for it. In this case just like the original poster I do expect top quality.

I can see that hose being more difficult for sure..

What happens when a tire blows out on your new trailer do you blame Malibu? I think the hose is a bit unexpected and the dealer you got the hose from seemed like he did the right thing by sending you a new one overnight.. I would think service like that should be commended and appreciated...

Just to clear things, I got PERFECT AWESOME Service from my dealer, and I m VERY HAPPY with him (ECFC in MA). My only concern was the QA process from Indmar, and my expectations from a very expensive product. We pay top $$$ in order to be able to use the VERY SHORT season we have around here.

BB

Share this post


Link to post
VinRLX
Huh? That's weird, my new piece of Shiet Moomba has about 75 hrs on it now, also taken over in March, but I havn't seemed to have any problems. Strange........... End Sarcasm. Sorry I feel better now.

You shouldn't feel better--you still have a POS Moomba.

:lol:

____________________________________

Boat problems are very frustrating. However, anyone ever have a blown tire? Did you blame the car manufacturer? Sensor problems on a new car? Recall issues where you had to make arrangements to be without your new ride and get to work while they made it right? Get frustrated, blow off steam, then get real.

Share this post


Link to post
WakeGirl
If it was that simple I would have done so.

It is the hose from the Thermostat to the circulating pump that has a very unique shape. I know from searching this forum that I m not the only person with a split hose.

After paying a big chunk of $$$ I do expect everything to be PERFECT. If I buy cheap I have low expectations, when I pay big cash there is usually a good reason for it. In this case just like the original poster I do expect top quality.

Good luck with that. Every manufacturer in every sector has a certain percentage of product failure, I don't care how much they're charging for the product. Bargain companies like Moomba have their problems as do the Big 3, & to expect perfection from any company is setting yourself up for failure. As was mentioned earlier, what defines & makes a company is how they handle situations like this. Both issues that were brought up in this thread have been addressed well by both dealers, so quite frankly I don't understand what the complaint is for either of you.

Share this post


Link to post
Hydrofoiljunky

Vin, As the shag master would say........Ouch baby, very ouch...........I think I laughed for a good couple minutes after your post. Thank you for that! Have a good one, and to the OP I hope they work it out for you man, that's what it's all about.

Chad

Share this post


Link to post
NorCaliBu
You shouldn't feel better--you still have a POS Moomba.

:lol:

Vin, As the shag master would say........Ouch baby, very ouch...........I think I laughed for a good couple minutes after your post. Thank you for that!

:lol: When I read Jack's comment I wondered how you would take it. Good for you for recognizing it as a joke...kinda like your boat. Whistling.gif

ROFL.gif

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...