Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
dennisvride

paranoid of having smoked impeller

Recommended Posts

dennisvride

Hey all,

I have a 2007 vride with lcr 320. Yesterday while running engine on hose at idle I was not paying attention to what I was doing and disconnected the water for 5 seconds before it dawned on me I didnt shut off the engine so I pluged the water back in and let it run. I am not usually this dumb but I was tired. My impeller has 10 hours on it.

1 What is the chance I did significant damage?

2 Even if you pumped the intake lines out of water momentarily wouldnt there be enough water residue to lube impeller briefly before the heat and damage started?

3 Do I have to inspect impeller before I go out again?

Thanks Dennis

Share this post


Link to post
99response

You are probably fine, just run the boat out of the water again and make sure it pulls water.

If you wanted the peace of mind, replace the impeller and keep the old one as your spare in case you loose one on the water.

-Chris

Share this post


Link to post
srud
Hey all,

I have a 2007 vride with lcr 320. Yesterday while running engine on hose at idle I was not paying attention to what I was doing and disconnected the water for 5 seconds before it dawned on me I didnt shut off the engine so I pluged the water back in and let it run. I am not usually this dumb but I was tired. My impeller has 10 hours on it.

1 What is the chance I did significant damage?

2 Even if you pumped the intake lines out of water momentarily wouldnt there be enough water residue to lube impeller briefly before the heat and damage started?

3 Do I have to inspect impeller before I go out again?

Thanks Dennis

5 seconds and not 5 minutes, right? Assuming that is indeed the case, the impeller is fine. Don't sweat it.

Share this post


Link to post
dennisvride

chris,

I run it on a garden hose with perko flush kit so it takes water pressure to get water past flush kit. I cant really see if it is sucking. When I plug the hose in the impeller seems to restrict 75% of the water from making it thru the block with the engine off. I am supposed to go out first thing in the morning and today is raining so changing the impeller is unlikely today.

When I put boat in water if it doesnt overheat at idle should it be good to go?. The thruhull has a scoop so while underway it should be forcing the water in while the pump is sucking.

Share this post


Link to post
lib135

I always run my boat for an extra 10 sec after I turn the water off to get all the water out of the manifolds.

Share this post


Link to post
99response

You can run the boat on the flush pro and still verify water flow.

1. feel the hoses upstream of the impeller (before the tranny cooler) and make sure you have good pressure. Also grab the circ pump hose an make sure you feel pressure there too.

2. The most obvious thing will be if water is coming out of the exhaust at a normal rate.

The good news is you still had water (lubricant) in the impeller housing when water flow stopped. Big difference between 5 seconds of dry spinning versus 5 seconds with water in the housing.

-Chris

Share this post


Link to post
99response
I always run my boat for an extra 10 sec after I turn the water off to get all the water out of the manifolds.

What do you own a freekin' jet ski!

Don't run the boat out of the water.

Share this post


Link to post
vette-ski

5 seconds, don't worry about it. That's not enough time for heat to build up to do any damage, especially if it was already wet. I always start my boat in the driveway before I head to the lake...just enough for the engine to run and then I shut it down. Nothing worse than showing up at the launch with a dead battery. I wouldn't think twice about the impeller spinning for 5 seconds.

Share this post


Link to post
99response
5 seconds, don't worry about it. That's not enough time for heat to build up to do any damage, especially if it was already wet. I always start my boat in the driveway before I head to the lake...just enough for the engine to run and then I shut it down. Nothing worse than showing up at the launch with a dead battery. I wouldn't think twice about the impeller spinning for 5 seconds.

I do the same thing, just fire it off quick so you don't look like a wally (same thing I guess) at the ramp.

Share this post


Link to post
dennisvride
I always run my boat for an extra 10 sec after I turn the water off to get all the water out of the manifolds.

And you never wore out the impeller?

Share this post


Link to post
dennisvride
Hey all,

I have a 2007 vride with lcr 320. Yesterday while running engine on hose at idle I was not paying attention to what I was doing and disconnected the water for 5 seconds before it dawned on me I didnt shut off the engine so I pluged the water back in and let it run. I am not usually this dumb but I was tired. My impeller has 10 hours on it.

1 What is the chance I did significant damage?

2 Even if you pumped the intake lines out of water momentarily wouldnt there be enough water residue to lube impeller briefly before the heat and damage started?

3 Do I have to inspect impeller before I go out again?

Thanks Dennis

5 seconds and not 5 minutes, right? Assuming that is indeed the case, the impeller is fine. Don't sweat it.

Yeah it was like 5 seconds give or take. How long would you have to run it dry to damage it at idle?

Share this post


Link to post
RTS

If the impeller were dry, it would likely start to heat up in about a minute or so, with damage coming a couple minutes after that.

5-10 seconds is no problem. I always start my boat before I back the trailer down the ramp, just to make sure it will fire up, and have never had any problems with the impeller.

Yours will be fine after a 5 second run dry period.

Share this post


Link to post
vette-ski
5 seconds, don't worry about it. That's not enough time for heat to build up to do any damage, especially if it was already wet. I always start my boat in the driveway before I head to the lake...just enough for the engine to run and then I shut it down. Nothing worse than showing up at the launch with a dead battery. I wouldn't think twice about the impeller spinning for 5 seconds.

I do the same thing, just fire it off quick so you don't look like a wally (same thing I guess) at the ramp.

A true wally would already be off the trailer and tied to the dock blocking off the ramp before he realized the battery was dead. Then he'd go get his truck again and try to jump start it, tieing up the ramp even longer.

If you guys are worried about smoking an impeller, consider changing to the Globe run-dry on your next swap. They aren't that much more than the stock impeller, and you can supposedly run those for 15 minutes out of water. In fact, you should PM D-Goose and see if he still has some left over from the recent group buy. I think that price was actually less than I paid for a stock one.

http://www.themalibucrew.com/forums/index....0&start=120

Share this post


Link to post
lib135
I always run my boat for an extra 10 sec after I turn the water off to get all the water out of the manifolds.

And you never wore out the impeller?

Never, and I have done it with every boat I have owned for years, you don't water just sitting in your manifolds.

Share this post


Link to post
vette-ski

You can't really blow water out of your manifolds, just the muffler if you have one. Exhaust and water don't mix until a couple inches after the turndown on the upper manifold. The lower manifold will always be full of water and you'll never be able to blow it out with exhaust flow. Manifolds holding water isn't that much different than the block holding water, is it?

Share this post


Link to post
jphillips

That is what I thought as well... was thinking the only way to get water out of there is to drain them.

Share this post


Link to post
stewart
If the impeller were dry, it would likely start to heat up in about a minute or so, with damage coming a couple minutes after that.

5-10 seconds is no problem. I always start my boat before I back the trailer down the ramp, just to make sure it will fire up, and have never had any problems with the impeller.

Yours will be fine after a 5 second run dry period.

Plus1.gif

Share this post


Link to post
99response
I always run my boat for an extra 10 sec after I turn the water off to get all the water out of the manifolds.

And you never wore out the impeller?

Never, and I have done it with every boat I have owned for years, you don't water just sitting in your manifolds.

Well after you try burning up your impeller for 10 seconds go ahead and disconnect the quick drain garden hose fitting on the manifolds and see how much water comes out of them.

Share this post


Link to post
Molarbu
I always run my boat for an extra 10 sec after I turn the water off to get all the water out of the manifolds.

And you never wore out the impeller?

Never, and I have done it with every boat I have owned for years, you don't water just sitting in your manifolds.

Well after you try burning up your impeller for 10 seconds go ahead and disconnect the quick drain garden hose fitting on the manifolds and see how much water comes out of them.

It's a dirty trick! Don't do it, you'll burn your fingers!!! Fingerwag.gif

Share this post


Link to post
zuluone

I live in the Mississippi and store my boat in a Garage. I will crank the motor ever month or so in the winter months for 10 or 15 seconds, long enough for the oil pressure to come up just to keep oil in all parts. Never had a problem with the impeller. But I always change every two years. When i do change, i inspected it and it looks normal. In other boats that I have had, I can't remember loosing a impeller before 3 or 4 years. I just use Murphys law and do every two. By next year, the impeller will be cheaper than a gallon of gas any way

Share this post


Link to post
Bill_AirJunky

For years on several boats, part of my winterizing & summerizing rituals have been to dry start the motor. I've only lost one impeller & it was more than a couple of years old.

We will ride late in the year & have to winterize the boat 4 or 5 times before we stop riding. We drain the engine, heater & manifolds, then dry start to blow out the last of the water, especially in the mufflers.

Then in the spring time, I'll usually try & get some water on to start the boat for the first time. But if we're heading right to the ramp, sometimes I'll just bump it to make sure the battery is good. This may be the worst for the impeller since it's truly dry in this case. But still never had a problem with it.

All that said, I'm running the Globe now, with my old Johnson as a backup.

Edited by Bill_AirJunky

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...