Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
GORDON

Water Leak

Recommended Posts

GORDON

Hello Crew,

Well I installed my new dry run impeller I purchased from the GB. Everything went great! I fired up the Bu, and checked for leaks. No leaks from the job I just finished, however, in checking things out to make sure all was OK, I noticed water dripping from a plastic tee at the bottom of the exhaust manifolds on both sides. These plastic tees were very loose. It looked like when the factory installed it they used white grease. I removed the plastic tees, and cleaned the white grease off and rubbed a little permatex on the threads. Installed tees back in, very carefully, not too tight, fired up the Bu, and no leaks. Just want to make sure what I did was correct, and that those tees were not left loose intentionlly by the factory. The boat is a 04 Wakesetter with the 340 monsoon. 80 hours. Thanks,

Gordon

Share this post


Link to post
NvBoarder
Hello Crew,

Well I installed my new dry run impeller I purchased from the GB. Everything went great! I fired up the Bu, and checked for leaks. No leaks from the job I just finished, however, in checking things out to make sure all was OK, I noticed water dripping from a plastic tee at the bottom of the exhaust manifolds on both sides. These plastic tees were very loose. It looked like when the factory installed it they used white grease. I removed the plastic tees, and cleaned the white grease off and rubbed a little permatex on the threads. Installed tees back in, very carefully, not too tight, fired up the Bu, and no leaks. Just want to make sure what I did was correct, and that those tees were not left loose intentionlly by the factory. The boat is a 04 Wakesetter with the 340 monsoon. 80 hours. Thanks,

Gordon

I would think that should be fine, I am not sure what plastic tee you are talking about, but I would assume that their shouldn't be any water coming out of any fittings around the motor. Take a pic and post it if you can. I'm sure someone else will put their two cents in.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...