Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
zzbutler

Illusion tower rattle...

Recommended Posts

zzbutler

Has anyone had a problem with the Illusion X tower rattleling?

Share this post


Link to post
Share on other sites
Boomer

Mine did on one side, pretty bad in rough water. Sounded like crap.

During my 10-hour service, I had it fixed by the dealer under warranty. I think they put some kind of bushing or shim or something, but no longer rattles.

Edited by Boomer

Share this post


Link to post
Share on other sites
woody

Ours does the same thing on the right side. We found the heli coil loose. WE fixed it on the spot, but it still rattled when the boat hit a hard wake.

Share this post


Link to post
Share on other sites
stusumm

I also had the exact prblem. The dealer fixed it right up. They added a bushing in the hinge area and had to tighten where the tower is attached to the boat. No noise now in about 50 hours. Clap.gif

Edited by stusumm

Share this post


Link to post
Share on other sites
stewart

Mine is going through this right now. My port side is slapping and my starboard side is squeeking

I went to the dealer and they didn't find a fix. So I called Metcraft. They said the towers are shipped off the boat, only the base is mounted at the factory. Apparently somewhere in transit or at the dealer a plastic bushing is getting lost. He is sending me a couple to install. Also, he said to make sure the front bolts have a "knurled surface" on them. These bolts are slightly bigger in diameter and can help reduce movement.

.

Share this post


Link to post
Share on other sites
wakeace
Mine is going through this right now.  My port side is slapping and my starboard side is squeeking

I went to the dealer and they didn't find a fix.  So I called Metcraft.  They said the towers are shipped off the boat, only the base is mounted at the factory.  Apparently somewhere in transit or at the dealer a plastic bushing is getting lost.  He is sending me a couple to install.  Also, he said to make sure the front bolts have a "knurled surface" on them.  These bolts are slightly bigger in diameter and can help reduce movement.

.

Where do the plastic bushings go? Front bolts? Rear bolts? or both? I did not see any on the rear when I colapsed mine. My tower was making some noise but seemed to go away after I tightened the bolts.

This is good info to have. Thanks Stewart.

Edited by wakeace

Share this post


Link to post
Share on other sites
stewart

The inserts go around the front bolts. You maybe able to see them when you collapse the tower.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...